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1. Introduction

1.1 Overview

Zirkonium is a set of macOS software tools to aid in the composition of spatial music; the software
enables composers to design multiple spatial trajectories with an intuitive GUI and arrange them
in time. According to the provided trajectory information, the actual audio signals can then be
rendered in real-time for virtually any type of 2D or 3D loudspeaker system.

The software was originally developed for the ZKM Klangdom (Sound Dome), a 3D surround
audio system consisting of 43 loudspeakers [Figure:1.1], but can also be utilized for any 2D and 3D
loudspeaker setup.

For developing Zirkonium MK III, we focused on improving the aspects of usability, visualiza-
tion, efficiency, and compatibility. Consequently, the software structure and the GUI were entirely
reassessed and redesigned from Zirkonium MK I and II. Furthermore, a number of functionalities,
such as a parametric trajectory generator, automatic interpolation, event filter, and expanded OSC
control are newly implemented.

Figure 1.1: Klangdom installed in the ZKM Kubus
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1.2 Features

Zirkonium MK III has following features:

Graphical manipulation of sound trajectories with bézier curves

Zirkonium facilitates the manipulation of highly complex sound trajectories. By multi-segmented
bézier curves, you are able to draw sound paths intuitively and flexibly.

Figure 1.2: A sound trajectory drawn with bézier curves

Parameter-based Trajectory Creation

The software offers another approach for trajectory creation. With “Add circle / spiral” popover
panel, you can generate spiral or circle-shaped trajectories algorithmically by inputting a few
parameters.

Figure 1.3: An example of parameter-based trajectory creation
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DAW-like Event Handling
All imported sound files are analyzed on load and the waveforms of the files are displayed in the
manner of DAW software. Furthermore, the software allows you to create special events graphically
on top of these waveforms, so that you can grasp the relationship between audio contents and
spatial events at a glance.

Figure 1.4: DAW-like editing of spatial events

Looks Like a Duck...
The event rendering looks like a DAW however it is important to note that Zirkonium is not a DAW
in that it’s ID / Group "track" audio handling is focused on the orignial use case of the project:
composers importing existing, prerendered multi-channel audio files for playback and spatialziation.
ID tracks are designed to be used with a single channel source (live or audio file) and there is no
provision for audio editing, cutting, or multiple sample arrangement.

Event Filtering
You may sometimes want to process a large number of spatial events at once. The powerful event
filtering feature of Zirkonium enables you to instantly select events that match provided conditions
and allows you to manipulate these events at once.

Figure 1.5: Editing the condition for event filtering

Quick Event Manipulation
In Zirkonium, all events are editable using the mouse, but it is also possible to edit them using text
input with the quick event manipulator. This assists you in setting up event start and end times or
accurately scaling the duration of an event.

Figure 1.6: Inputting time for event time shifting in quick event manipulator
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Powerful Visualization of Spatialized Sound
All waveform images of sound file contents are utilized in Dome view and Motion view. In Dome
view, the waveforms are rendered along their associated sound paths, thus enabling you to grasp
the relationship between audio contents and their positions in space.

Figure 1.7: Waveform rendered along a sound path

Variety of Rendering Algorithms
Zirkonium currently features two types of spatial rendering algorithms: VBAP (Vector Based
Amplitude Panning) and HOA (Higher Order Ambisonics). In Zirkonium, you are able to assign an
algorithm for each ID (sound object) and employ both algorithms simultaneously. For Ambisonics,
further options for optimization (in phase and maxRe optimization) are available.

Figure 1.8: Domeview displays active VBAP speaker triplet during playback

HRTF Simulation
With the HRTF (Head Related Transfer Function) algorithm, Zirkonium realizes a virtual 3D sound
for headphone listening. This functionality enables you to continue working on your composition
in any kind of environment.

Figure 1.9: HRTF mode button
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Customization of Core Spatial Rendering Algorithm
In principle, the spatial rendering algorithms in Zirkonium are optimized for 3D surround systems,
such as the Klangdom. Additionally, the software grants you access to the core spatial algorithms
written in Pd (Pure Data). By modifying the internal server patches, you can tune the system for
other surround systems or utilize it in Pure Data directly.

Figure 1.10: Spatial Rendering Algorithm is implemented as a Pd Patch

Synchronization with other software through OSC or MIDI
Zirkonium is able to synchronize with other software environments that are compatible with OSC
(Open Sound Control), MTC (MIDI Time Code), or MIDI Clock. This feature is useful, for example,
to synchronize a video file running on another application like the included ZirkVideoPlayer, while
playing back audio from Zirkonium.
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1.3 Architecture

Figure 1.11 illustrates the software architecture of Zirkonium. All GUIs are developed with Cocoa,
OpenGL, and GLSL. Apple’s Core Data is utilized for data management.

The spatial rendering functionalities are programmed as Pure Data patches and external objects.
The main Pd audio server patch, as well as Pure Data sound processing engine and abstractions, are
embedded in the Zirkonium using libpd.

Audio signals, processed by embedded Pd, are sent to the audio hardware through Port Audio
and Core Audio.

Zirkonium Trajectory Editor

GUI

Data 
Management

Spatial Rendering Engine

Cocoa OpenGL

Port Audio

LibPd

Core MIDI Core Audio

Spatialisation
Server

Pd Patch

SpatDIF 
Library

Audio Interface

Core Data

Other Software

Speaker
Setup 
XML

Zirkonium
FIle

SpatDIF
XML

Audio
File

Other Software

OSC
MIDI

Figure 1.11: Software Architecture

1.4 Dependencies

Zirkonium employs the following open source libraries in addition to macOS Cocoa framework:

1.5 System Requirements

The system requirements for Zirkonium are:
1. Operating System: macOS 10.12 or higher
2. CPU: Apple Silicon or Intel Core i5 (minimum)
3. RAM: 4 GB (minimum)
The software is tested and evaluated on macOS 15 (Sequoia).
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Name License Author URL

Pure Data Standard Improved BSD Miller Puckette https://puredata.info
libpd Standard Improved BSD Peter Brinkmann, Dan Wilcox, et al. https://github.com/libpd/libpd
Port Audio MIT Ross Bencina https://www.portaudio.com
HOA Library GPLv3 Julien Colafrancesco et al. & CICM https://hoalibrary.mshparisnord.fr/en

Table 1.1: Dependencies

1.6 What’s in the package

In the Zirkonium package, you will find three separate applications.
1. Zirkonium3
2. Speaker Setup
3. ZirkVideoPlayer
Other than Zirkonium3, the main application, the Zirkonium package includes two more

applications, Speaker Setup, and ZirkVideoPlayer.
Speaker Setup is an application for configuring speaker setups in 2D or 3D space. This

application is able to export a XML file that defines speaker positions in a space. These XML files
can be loaded by Zirkonium and presented on the Dome view for defining your own speaker setup.
For details see chapter 10.

ZirkVideoPlayer is a simple Quicktime player that is capable of receiving OSC Messages from
Zirkonium. This software enables you to synchronize sound tracks that spatialized with Zirkonium
and a movie file. For details see chapter 11.

1.7 Installation

For the installation, simply copy the Zirkonium3 folder containing all three applications to your
Applications folder.

1.8 The Coordinate System of Zirkonium

There are many different coordinate systems for describing a position in 3D space. Zirkonium and
the Speaker Setup application adopt the head-related coordinate system, defined by Jens Blauert in
his book entitled Spatial Hearing: The Psychophysics of Human Sound Localization.

0
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-90 180
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90
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Figure 1.12: The Coordinate System of Zirkonium

https://puredata.info
https://github.com/libpd/libpd
https://www.portaudio.com
https://hoalibrary.mshparisnord.fr/en
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In this coordinate system, the relationship between the listener and Azimuth is defined as follows:
• Front ... 0◦

• Left ... -90◦

• Back ... 180◦ or -180◦

• Right ... 90◦

The relationship between the listener and the Elevation is defined as follows:
• Above (Zenith) ... 90◦

• Below (Nadir)... -90◦

The relationship between the listener and the Cartesian axes is defined as follows:
• Left ... x-
• Right ... x+
• Front ... y+
• Back ... y-
• Above ... z+
• Below ... z-

Figure 1.12 depicts the relationship between the listener and both Spherical and Cartesian coordi-
nates used in Zirkonium.



2. GUI overview

You can create, open, or reopen files using the File -> New / Open / Open Recent options. After
you create a new document, a new window should appear on the screen [fig:2.1].

Figure 2.1: New window

The window consists of following five components:
• Table View
• Dome View
• Motion View
• Event View
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• Transport Bar
This chapter describes an overview of the functionalities of each component. For details, see

chapters 4 - 7.

2.1 Table View

This view displays all data in the current project in tables. The view is comprised of three tabs;
Sources, IDs/Groups and, Events.

Figure 2.2: Table view tab

Sources Tab

This is the start point of your spatial composition. The table in this tab lists all imported sound files
and the ever present live input source. You can add new files to this list for playback or remove
previously added files.

IDs/Groups Tab

This tab has two tables. The top table is called IDs Table and the bottom table is called the Groups
Table. Here you can define IDs (sound objects) and Groups of IDs. For ID and Group details, refer
to chapter 5 and 6.

Events Tab

All events of IDs, Groups, and Markers in the piece are listed here. You can add, delete, or modify
single or multiple events in this tab. At the bottom of the tab, there is a group of pop-up menus and
text fields. This is called the Quick Event Manipulator. This small GUI component enables you
to quickly modify the properties of selected events without having to change them individually.

Figure 2.3: Sound path in the Dome view
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2.2 Dome View
The Dome view is a canvas for the Sound Path. Using bézier curves, you can design the paths
of the sound trajectory for each spatial event. During playback, this view visualizes active sound
paths, the level of audio signals sent to each loudspeaker, the movement of each ID, and selected
loudspeaker triplets by the VBAP algorithm in real-time [fig:2.3].

2.3 Motion View
In the Dome view, you draw paths that sound objects (ie. IDs) move along. Obviously, a sound
path has a start and an end point, however it does not necessarily mean that all IDs move from the
start point to the end point at a constant speed. In the Motion view, you can draw a Motion Path
that determines at what speed IDs move along the corresponding sound path. Furthermore, this
view also provides control over the event’s Span Path and Gain Path. The Span Path represents
the spatial size of each ID in time and the Gain Path represents the gain over the course of the
trajectory.

Figure 2.4: Motion Path in the Motion view

2.4 Event View
This View shows all spatial events in the manner of a DAW (Digital Audio Workstation) software
suite. The X-axis represents time. Events assigned to each ID are represented as gray rectangles in
the view, and the movements of each ID is displayed as solid and dotted white lines in the rectangles.
The thumbnails of the corresponding sound paths are rendered on top of them.

Figure 2.5: Events displayed in Event View

2.5 Transport Bar
Transport bar consists of seven buttons, three text fields, the master volume slider, and the HRTF
button. The functions of each are described below:

Figure 2.6: Transport Bar
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Rewind Button
Set the position of the playback cursor to 0:00:00.00.

Jump To Previous Marker
Set the current time to the time of the previous marker. If no previous marker is found, it jumps to
0:00:00.00.

Jump To Playback Start Time
Set the current time to the start time of the previous playback. This is useful if you want to listen to
the previously played part once again. In the event view, this position is indicated with a dark green
vertical bar.

Play/Pause Button
When clicked, Zirkonium starts to play the piece back from the position where the playback cursor
is located. If clicked again, the playback is paused.

Record Button
When this button is turned on, real-time drawing of trajectories with the mouse on the Dome view
is enabled for record armed IDs during playback, automatically creating an event. This also enables
recording live OSC ID and Group movement to events.

Jump To Next Marker
Set the current time to the position of the next marker.

Loop
If activated, the playback is looped between the loop start time and the loop end time.

Playback Cursor Position
This field indicates the position of the playback cursor. This field is editable and you can input a
time that you would like to jump to.

Piece Duration
This field shows the duration of the piece. Zirkonium determines the duration of the piece automati-
cally by comparing the end time of the last event and the duration of the longest sound file, and
adopts the longer one as the piece duration. This field is not manually editable.

Loop Start Time
This field sets and displays the start time of the loop.

Set Loop Start Time with Playback Cursor Position
Copy the current time indicated in the Playback Cursor Position field to the Loop Start Time field.

Loop End Time
This field sets and displays the end time of the loop.

Set Loop End Time with Playback Cursor Position
Copy the current time indicated in the Playback Cursor Position field to the Loop End Time field.

Master Volume Slider
This slider controls the overall master volume of the piece from -100 to +3 dB. Right-click to return
to the default of 0dB.
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HRTF Button
When this button with a headphones icon is enabled, all audio signals are fed through a simple
binaural HRTF algorithm to simulate virtual 3D audio for headphone listening. The processed
sound is sent to channel 1 and 2 by default and can be changed in the Zirkonium preferences.

Sync mode pop-up
With this pop-up menu, you can select synchronization mode. Refer to section 9.4 of chapter 9 for
details.





3. Setting up

3.1 Setting Up Loudspeakers

The first thing that needs to be done after launching the software is to load the position of each
loudspeaker in space. A stereo configuration is used by default.

Figure 3.1: 5.0 Speaker Setup loaded on Dome View

3.1.1 Standardized Speaker Setup
To set up a standardized loudspeaker configuration, such as stereo, quadraphonic, or 5.0 [fig:3.1],
simply select one of the preset speaker setups from the File -> Load from XML File menu.
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3.1.2 Custom Speaker Setup
If you would like to use a speaker configuration not listed in the preset menu, use the Speaker
Setup application to configure your own setup and export the configuration as an XML file. For
details, refer the chapter 10.

By selecting File -> Load Speaker Setup -> Load from XML File, you can load your custom
speaker configuration to Dome view.

3.2 Audio Settings
There are 2 types of settings, based on how they are saved and what they affect:

1. Zirkonium Preferences: global app preferences, saved with user account
2. Project Settings: project-only settings, saved with project file
To access the Zirkonium Preferences, select Zirkonium3 -> Settings.
Project settings can be configured with the File -> Project Settings panel. To open the project

audio settings tab, for instance, select File -> Project Settings -> Audio Settings.

Figure 3.2: Project Audio Settings

Following, is a description of each item in the project settings tab.

3.2.1 Zirkonium Audio Preferences
Audio Backend
Portaudio Default audio input library which use CoreAudio internally.
Jack JACK inter-application audio server. Supported since Zirkonium 3.4.

The Portaudio backend lists audio devices found when Zirkonium is started and does not
currently support hot-plugging. To see additional devices added later on, restart Zirkonium.

R For some devices which may not have an audio input (newer Mac minis with headphones
plugged in), there is a default dummy "none" Portaudio input device. This can also be used
for a set up which does not need the Live Input source.

JACK support is dependent upon the Zirkonium version and which build of JACK is installed
on your system:
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Zirkonium 3.7+: the JACK2 macOS installer from https://jackaudio.org/downloads or
installed via Homebrew

Zirkonium 3.4 to 3.6: the older 32-bit JackOSX JACK1 installer
To use JACK, install JACK to your system, start the JACK server, then choose the JACK

audio backend in the Zirkonium Audio Preferences. When finishing a session, make sure to close
Zirkonium first (or switch the audio backend to Portaudio) before stopping the JACK server.

When using JACK, Zirkonium provides 64 input and outputs.

Buffer Size
Set the preferred audio buffer size in number of samples per frame. A smaller sample rate will
result in lower latency which is useful for live input but at the expense of higher CPU usage and
possible audio drop outs on slower systems. A higher buffer size will result in smoother audio
handling but longer latency and less live input responsibility. The default is 512.

Input Device
Select a hardware device for audio input from the pop-up menu. You can receive audio signals
not only from physical devices connected to the computer but also other software running on the
computer by installing Black Hole, Soundflower (historical), or similar audio loopback utilities.

The max channels text box allows for limiting the number of input channels in order to lower
the amount of audio processing. For instance, on a MADI-enabled system with 40 speakers, the
maximum of 64 channels may not be needed and can be limited to the required 40, starting from
channel 1. Clear the text box to return to the default of using the maximum available channels.

This option is disabled with the JACK audio backend.

Output Device
Select a hardware device for audio output from the pop-up menu.

Similar to the Input Device section, the maximum number of output channels used can be
limited via the max channels text box. Clear the text box to return to the default of using the
maximum available channels.

This option is disabled with the JACK audio backend.

3.2.2 HRTF Output Channels
These options set the output channels used when the HRTF "headphone mode" button is enabled.
On some systems, a separate set of channels distinct from the overall speaker system output is
desired. The default HRTF output channels are 1 and 2.

3.2.3 JACK Autoconnect
This option enables automatic connection to the available JACK system input and output channels.

3.2.4 Project Audio Settings
Sample Rate
Select sample rate from 44100, 48000 or 96000 Hz, using this pop-up menu. It is highly recom-
mended to set the sample rate before importing sound files to the software. The default sample rate
is 48000.

Zirkonium performs sample rate conversion between the (internal) project sample rate and
(external) input/output audio devices:

Input Device -> (convert) -> Zirkonium project -> (convert) -> Output Device
For performance and simplicity, conversion is not performed when source files have different

sample rates than the (internal) project sample rate setting. Playback works but source file pitch
may be affected.

https://jackaudio.org/downloads
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3.2.5 Speaker Output Patching
A speaker setup must be loaded to edit this table, in it, you can configure the following output
parameters for each speaker:
Index The index of speaker as defined in the Speaker Setup XML File. This parameter is not

editable.
Channel Output channel of the audio hardware (e.g. your audio interface) assigned to each

speaker.
Gain The gain of the speaker in dB. 0 means unity (bypass).
Delay Delay time in ms applied to the speaker. This parameter is useful for avoiding comb filter

effects caused by irregular speaker setups.
Invert Phase If checked, Zirkonium inverts the signal output of the specified speaker.

R These settings are saved with the project and will be cleared and reset when loading a new
speaker setup. To keep a separate copy of the currently loaded setup, export to an XML file
via File -> Export Speaker Setup.



4. Importing sources

4.1 What is a Source?

In Zirkonium, the term source represents all kinds of audio data that can be utilized for spatialization.
A source can be in form of a sound file, such as “mysound.wav” stored in the hard drive, but it can
also be a live signal coming directly from an audio interface attached to your computer.

4.2 Sources Table

The source table lists all available sound sources. Each column of the table describes a property of
the sources [fig:4.1].

Figure 4.1: Sources Table

Source Name
The name of the imported audio file

Format
The format of the imported audio file: WAVE, AIFF, or CAFF

Ch
The number of audio channels
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Duration
The duration of the audio file in h:mm:ss.cs format

SR
The sample rate of the file

Depth
The bit depth of the file (16, 24, or 32)

Gain
Gain adjustment to apply on playback. Default is 0 dB (unity).

Assigned
IDs that currently use this file

Location
The full path of the file’s parent folder

R Live Input represents the audio input from your audio interface or microphones attached to
or embedded in your computer. This entry is always available in the source list.

In case you use software that transfers audio signal from one application to another application
such as Black Hole or SoundFlower (historical), select "Live Input" for receiving the audio
signal from said software.

R When sound files are imported, Zirkonium creates their waveform images. This happens
in the background and may take several seconds, depending upon the sample rate and the
duration of each file.

4.3 Adding and Removing Files

To add sources to the project, simply drag and drop sound files onto the “Sources” table, or click
the “+” button below the table and select files from the open panel. Multiple files can be added at
the same time.

To remove source file(s) from the sources table, simply select the files you wish to delete and
press backspace.

4.4 Acceptable File Formats

Zirkonium currently only accepts sound files that have the following properties:

Number of Channels
• 1 - 8

File Format
• AIFF
• WAV
• CAFF
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Sample Rate
• 44.1 kHz
• 48 kHz
• 96 kHz

Bit Depth
• 16 bit (float and integer)
• 24 bit (float and integer)
• 32 bit (float only)

R Source file sample formats should be uncompressed PCM float or integer, except for 32 bit
integer which is not supported by Pure Data.

The sample rate of the file should conform to the sample rate of the project. If the sample rate of
the file does not match the sample rate of the project, these files are assignable to IDs however the
pitch will.

To change the sample rate of the project refer to chapter 3.2.

You can remove a sound file assigned to an ID from the sources table. If you do this, the
associated IDs lose the connection to sound file, but it remains in the IDs list. The events
associated to an ID are also retained in the event table for later usage.

4.5 Changing or Reconnecting Source Files
To change source files without losing the associated IDs and/or reconnect files missing on load,
right-click on the Sources table to show a context menu with the following options:

• Change Selected Source File: select a new source file for selection
• Locate Missing Files in Folder: select a folder to search for missing files
• Show in Finder: open a Finder window showing the selected file





5. Creating IDs

5.1 What is an ID?

ID refers to a sound object in Zirkonium. Before a sound source can be moved in space, you need
to create an ID and assign it a source (sound file or live input channel).

In Zirkonium, the number of channels that are assignable to single ID is always one (i.e. mono).
If you want to move a stereo source in a space, import a stereo file, create two IDs, assign each
ID to each channel of the imported stereo file, and use the individually or group them together
using the grouping functionality described in chapter 6.

5.2 IDs Table

Figure 5.1: IDs Table

The IDs table, located at the top of the IDs / Groups tab[fig:5.1], shows all IDs in the project
and displays the properties of each ID listed below:

ID

The index of the ID assigned automatically by the software. This value is not editable.
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Color
The color that represents the ID. When this cell is clicked, a color picker floating window should
appear and let you choose the new color for the ID.

Source
The audio source (sound file or live input) assigned to the ID.

Label
The optional name of the ID.

Group
The group that the ID belongs to.

Algorithm
The spatial rendering algorithm assigned to the ID.

VBAP Vector Based Amplitude Panning (Default).
HOA High Order Ambisonics.
OSC Open Sound Control. If this option is selected, Zirkonium does not process the

audio signal and simply sends the position of the ID as OSC messages. This
option is useful if you want to control another software environment or hardware
with Zirkonium.

None Do not output any audio from the ID, unless D-out (Direct Out) is activated.

Optim
Optimization option for HOA Spatial rendering algorithm.

When HOA (High Order Ambisonics) is selected as the spatial rendering algorithm, an opti-
mization option for the algorithm becomes selectable and you can choose one of the following
optimization options. The definition of the three optimization options by the CICM (developer of
HOA library) are as follows:

Basic has no effect, it should be used with a perfect Ambisonics channel arrangement
where all the channels are to equal distance on a circle or a sphere, and for a
listener placed at the perfect center of the circle of the sphere.

MaxRe should be used for an auditory space confined to the center of the circle of
the sphere.

InPhase should be used when the auditory space covers the entire channel area and
when the channel arrangement is not a perfect circle or sphere or when the
channels are not to equal distance.

The Ambisonics order is optimized automatically by the software, based on the number of
loudspeakers; higher number of loudspeakers requires a higher Ambisonics order. Thus, CPU
consumption by HOA may increase with a higher number of loudspeakers.

Ch
The channel assigned to the ID. When the source is mono, the pop-up is disabled.

Gain
Gain adjustment to apply on playback. Default is 0 dB (unity).
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D-Out
Direct Out. When assigned, the source signal will be routed directly to the selected audio hardware
output.

D-Out is useful when you want to send a sound source to a single specific speaker or send it to
another external processor.

5.3 Creating a new ID
To add an ID to Zirkonium, switch to the “ID/Groups” tab, then click the “+” button below the
upper table to add a new ID.

When an ID is added to the IDs table, an initial event is created and the position of the ID is
set. IDs are automatically placed in a circle starting toward front and advance clockwise with a
spacing of 30 degrees for each additional. unless they are manually moved, the positions will start
to overlap after after 12 IDs.

This initial event is not manually removable from the event table and most of the properties of
the initial event are not modifiable by the user except the initial position. An initial event is
automatically removed when the corresponding ID is removed from the IDs table.

5.4 Assign a source file to an ID
Simply click on the pop-up menu and select the source you want to assign to the ID.

Auto Connect IDs
In case a source has multiple channels and a connection between every channel and an ID is wanted,
hold Opt/Alt when pressing the add ID button (+) to automatically connect the new ID to the source
target of the previous ID in the list and increment the channel.

If there are no IDs, the first ID will be connected to the Live Input source, channel 1. If there
are IDs currently selected, the last ID in the selection will be used for the previous ID. If the target
is empty or the previous ID is already using the last channel, then no connection will be made.

5.5 Deleting ID(s)
To delete IDs, select one or multiple IDs listed in the IDs table and press the backspace key.

R Caution: All spatial events associated with the deleted ID will also be deleted from the event
list.





6. Bundling as Groups

6.1 What is a Group?
A Group represents a set of multiple IDs moving together. Grouping allows us to move several
IDs along a single sound path. All IDs, belonging to a Group, are called member IDs of a group.
A group must have a single Master ID, all the other IDs in that group are called Slave IDs. The
Master ID moves along the sound path and each slave ID follows the master ID, keeping the
distance or angle between them [fig:grouping].

Figure 6.1: Grouping

R If a master ID is assigned, you are only able to draw a sound path for a group. The Master ID
can be selected in the Groups table.

6.2 Groups Table
The Groups table shows detailed properties of each group.
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Figure 6.2: Groups Table

Label
The name of each group. It is highly encouraged to provide each group with a specific name. By
default, groups receive placeholder names with their numeric index, ie. Group-1.

Member IDs
This column displays IDs that belong to the group. Not editable.

Master ID
The leading ID of the group

Mode
The mode of the group which determines how Slaves follow the Master ID. The available modes
are listed below and are discussed in 6.11 in detail.

Translate-Fixed During a group event, the Cartesian distance between the master ID
and all slave IDs is determined by the Cartesian distance of the initial position.

Rotate-Fixed During a group event, the spherical distance between the master ID and
all slave IDs is determined by the spherical distance of the initial position.

Translate-Free Same as Translate-Fixed, but in this mode, the relations between
positions will adapt to a new arrangement caused by individual events of the
member IDs.

Rotate-Free Same as Rotate-Fixed, but in this mode, the relations between positions
will adapt to a new arrangement caused by individual events of the member IDs.

Mirror The number of members of this mode must be two. The position of the slave
is always equal to the position of the master, mirrored along the Y axis.

6.3 Creating a Group

To create a group, click the “+” button below Groups table and a new group should added in the
table.

Auto Connect Groups

Hold the Command key while clicking on rows in the IDs table to select multiple IDs, then hold
Opt/Alt when pressing the add Group button (+) to auto connect these IDs into the newly created
group. If any of the selected IDs are already master IDs of an existing group, an error message is
shown and the ID is skipped, ie. not connected to the new group.

6.4 Naming a group

To name a group, double click on the label cell of a group and type the name in. The name will be
set when the return key is pressed or when you click somewhere else.
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6.5 Adding a member to a group
To add an ID to a group, select the desired group from the group column of the ID in the IDs table.

6.6 Removing a member from a group
To remove an ID from a group, select another group or "None" in the IDs table. Note, you can not
remove the master ID from a group via the IDs table. If you want to remove the master ID from a
group, change the Master ID in the group table first, then remove it.

6.7 Setting a Master ID
To select the master ID of a group, click on the master ID pop-up cell in the Groups table, and
select an ID from the member IDs. A sound path for a group cannot be drawn, unless a master ID
is assigned.

6.8 Selecting the group Mode
To select a group mode, click the pop-up menu and select one of the available five modes. The
difference between the five modes is described in 6.11.

6.9 Changing the group an ID belongs to
To change the group that an ID belongs to, simply select another group in the ID table. To remove
an ID from a group, select "None" from the pop-up.

6.10 Deleting a Group
To delete a group, select a group or groups in the list and press the backspace or delete key.

When you delete a group. All events that control the deleted group will lose their target but will
remain in the event table. You can then associate these events with another ID or Group.

6.11 Which group mode to select
Group modes select the relationship of the movement between master and slave IDs. You can
select a group event mode from one of the following: Translate-Fixed, Rotate-Fixed, Translate-Free,
Rotate-Free, and Mirror.

6.11.1 Translate and Rotate
In the translate modes (Translate-Fixed or Translate-Free), the Cartesian distance between each ID
and master ID is kept unchanged and the size of the group is constant. The relationship between IDs
and the listener varies, however, depending upon the position of the group. As the figure 6.3 shows,
the group creates a stereo image if it is placed in front of the listener, but the distance between the
ID’s becomes indistinguishable if it is moved to the left or right side of the listener.

In contrast, in the rotate modes (Rotate-Fixed or Rotate-Free), the spherical distance (or angle)
between each ID and Master ID is kept unchanged. You can take full advantage of this mode if you
move the group in a circular manner (rotating around the center).

This mode causes two possibly unwanted side effects. Firstly, the Cartesian distance or the
size of a group is changed, depending upon the elevation. If a group moves towards the zenith, the
distance between IDs is reduced, and if a group moves towards the horizon, the distance between
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Figure 6.3: Translate Mode

IDs expands. Secondly, the formation of a group will be mirrored if the group travels through the
zenith.

Figure 6.4: Rotate Mode

6.11.2 Fixed and Free

Fixed mode means the distance between the master ID and each slave ID is determined by the
initial position of each ID. This means that the initial formation cannot be changed. If any ID
moves independently after said movement, the formation is reset to the initial one. This mode is
useful if you want to keep the formation of a group unchanged throughout a piece.

In Free mode, the distance between master and each slave ID is determined by the final position
of the latest individual single ID event. The initial formation adapts to any individual ID movements
that may occur, retaining the most recent formation. This mode is useful if you want to change the
formation of a group in a piece.
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6.11.3 Mirror mode
The Mirror mode is a special mode and different from the other four modes. The number of
members in a mirror-mode group must be 2. The position of the slave ID is always mirrored along
the Y axis. If the position of the master is (x, y) the position of slave is always (-x, y). Because of
this exceptional behavior of the slave, there is no option for fixed or free mode (Fig. 6.5).

Figure 6.5: Mirror Mode

R The mirror mode is useful when you want to keep the stereo image of the sound sources
balanced.





7. Managing events

7.1 What is an Event

In Zirkonium, all spatial movements of IDs and Groups are called Events. Usually an event has a
start time and an end time.

An event has several properties that are related to either time or space. To edit the time-related
properties, such as start time and end time, we use the event table or the event view. To edit the
space-related properties, such as sound path or motion path, we use the dome view and the motion
view.

There are two special types of events: initial event and marker event. Initial events determine
the initial position of an ID. A marker event represents a certain time point of the piece, for example
the beginning of a section, and doesn’t possess spatial properties or an end time.

7.2 GUI Overview

7.2.1 Event Table

Figure 7.1: Event Table
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Click the “Event” tab to display the event table. In the event table, all events are listed
chronologically. You can directly modify some of the properties in the table. The descriptions of
the properties are as follows:

Target
You can select the target of each event in the pop-up menu: Group, ID, or Marker. The default
setting is “None”. The dome view and motion view are disabled unless you select an ID or a Group
target.

Label
The name of each event. This label will be displayed in the dome view, if the visibility of the event
name is enabled in View -> Dome View -> Sound Path -> Event Name.

Start Time
The start time of the event in h:mm:ss:cs format. You cannot set a time after the end time of the
piece.

End Time
The end time of the event in h:mm:ss:cs format. You cannot set a time before 0:00:00:00. This cell
is disabled for marker events.

Type
The type of each event indicated with a letter: U, I or T.

(U)ndefined An undefined event has no anchor points. The event does not move the position of
it’s target.

(I)nstantaneous An instantaneous event has only one anchor point and the ID moves to the
position of the anchor point instantly when the play cursor reaches the start position of the
event.

(T)rajectory A trajectory event has more than one anchor point in its sound path and the ID moves,
in principle, from the start to end position over the duration of the event.

Len
The length of the path measured in relation to the radius, where the radius of the unit circle is 1.0.

Figure 7.2: Length of a sound path
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Speed
The average speed of the trajectory in radii per second, computed form path length and duration.

Centroid
Zirkonium internally converts (rasterizes) the sound path drawn with bézier curves to a large number
of points, in order to optimize playback. At the same time, it calculates an average coordinate of
these points. This average coordinate is called the Centroid and indicates the approximate spatial
center of the sound path. The centroid is shown in the dome view as an outlined circle.

7.2.2 Dome View
The Dome View is the main canvas of Zirkonium. Here you can draw sound paths freely with
bézier curves.
The most important GUI elements of the Dome View are listed below.

Figure 7.3: Dome View

Speaker Object
The position of each Speaker is indicated as a green square and the layout indices defined in the
loaded Speaker Setup XML file are shown.

Dimensionality
This shows the dimensionality of the current speaker setup, either 2D or 3D. The dimensionality
is defined in the Speaker Setup XML file and is not modifiable in the Zirkonium GUI. The CPU
resource consumption significantly increases if the loaded setup is 3D.

Sound Path
The actual path that an ID moves along over the duration of the event. The color of the sound path
is determined by the color of the ID. The following are graphical symbols attached to the sound path:

Start / End Position The triangle symbol indicates the start position of a sound path,
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and the cross symbol indicates the end position. At the start time of an event, an
ID starts to move from the start position, and it reaches the end position by the
end time of the event.

ID Circle This filled circle indicates where the ID is currently located along the sound
path.

Centroid The geometrical center of the trajectory, represented as an outlined circle.
Waveform Representation in space of the audio in the associated source file along the

sound path.
Span Band The size or expansion of the ID represented as a band.
Anchor Point Represented as solid white squares, these are “joints” of multiple bézier

curves.
Bézier Handles These handles are used to control the arch of each bézier curve.

Select Tool
When active, you can select items in the dome view, motion view, and event view.

Pen Tool
When active, you can add anchor points in the dome view or motion view and create event regions
in the event view.

R You can switch between Select Tool and Pen Tool quickly by the keyboard short-cut: Com-
mand+E.

Transform Tool
When selected, you are able to translate, rotate, and scale the sound path in the dome view.

Snap To Previous Event End Button
The start position of the currently selected sound path will be matched to the transparent cross (i.e.
the end position of the sound path of the previous event). By matching these two points, you can
avoid abrupt jumps of the ID position from the previous event.

Snap To Next Event Start Button
The end position of the currently selected sound path will be matched to the transparent triangle
(i.e. the start position of the sound path of the next event). By matching these two points, you can
avoid abrupt jumps of the ID position to the next event.

Center View Button
Center the Dome View.

Span Draw Size Slider
This slider controls the size of the span band displayed in the dome view. Note: this slider modifies
only the visual representation of the and does not change the actual span path.

Waveform Draw Slider
This slider controls the size of the waveform attached to the sound path. Note: this slider modifies
only the visual representation and does not change the actual amplitude of the audio.

Trash Button
When clicked, the sound path shown in the dome view, will be deleted instantly.
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Visibility Control

The visibility of each GUI component is configurable with the Dome View menu under the View
menu. The Dome View menu has three sub-menus: Speaker, Sound Path, and Grid. The details of
each menu item are listed in the tables 7.2 - 7.3.

Object show/hide the speakers (depicted as green squares)
Index show/hide the layout index number of each speaker
Output show/hide the hardware output number associated with each speaker
Ring show/hide the rings (speaker groups)
Triplet show/hide the loudspeaker triplets and currently selected triplet used in the VBAP algorithm
Gain show/hide the gain of each speaker
Level (color) if activated, the output level of each speaker is color-coded from green to red

Table 7.1: Speaker Sub Menu

Ruler show/hide the ruler
Waveform show/hide the waveform displayed along the sound path
Centroid show/hide the geometrical center of the sound path
Event Name show/hide the name (label) of the event that the sound path belongs to
Event Mute display the sound path of the event in gray if it is muted
ID Level display the level of the ID represented as a circle around the ID circle
ID Index display the ID Index inside the ID circle

Table 7.2: Sound Path Sub Menu

Grid show/hide the 10x10 grid in the dome view

Table 7.3: Grid Sub Menu

7.2.3 Motion View

The motion view is an editable line graph that represents the relationship between time (X-axis)
and the relative position of an ID along a sound path (Y-axis).

As written previously, a sound path has a start position and an end position which are marked
with a triangle and a cross symbols, respectively. When editing the motion path, the vertical line on
the left edge of the view is called the Mini-Sound Path and it represents the tightened up version
of a sound path, drawn in the Dome View. When editing the span or gain values, the scale of the
respective values is shown on the left instead.

The descriptions of graphical components in the Motion View are as follows:

Start Time
The start time of selected event.

Duration
The duration of selected event.

End Time
The end time of selected event.
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Figure 7.4: Motion View

Mini-Sound Path
This is a compact representation of a sound path drawn in the dome view. The start position of a
sound path corresponds with the bottom end, and the end position corresponds with the top end of
the Mini-Sound path. The Mini-Sound Path also displays the relative position of anchor points on
the sound path.

Motion, Span, and Gain Path Modes
If the span mode is selected the span path is displayed, representing span size on the Y axis, from 0
to 100%. If the motion mode is selected, the view represents the position on the sound path in the
Y axis from event start to end. If the gain mode is selected, the view represents the event’s gain
over time in decibels, from -100 to +6 dB. These modes can be alternated by pressing the buttons
on the right side of the motion view with the current mode denoted by a highlight color.

Waveform
The waveform of sound file audio content to be played during the selected event.

Motion Mode Button
You can switch to the motion mode by clicking this button.

Span Mode Button
You can switch to the span mode by clicking this button.

Gain Mode Button
You can switch to the gain mode by clicking this button.

Trash Button
When clicked, motion, span, and gain paths will be reset.

Visibility Control

The visibility of each GUI component is configurable in the View -> Motion View menu.

Waveform show/hide the waveform displayed along the span, motion, or gain path
Ruler show/hide the ruler
Anchor Point Lines show/hide horizontal lines from the anchor points on the Mini-Span Path

Table 7.4: Motion View Visibility Control

The “Anchor Point Lines” option is useful when matching certain audio events to a position
along a span, motion, or gain path. For details refer to 7.6.2.
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Figure 7.5: Anchor Point Lines disabled and enabled

7.2.4 Event View

The Event view visualizes the created events along the timeline graphically in the manner of DAW
(Digital Audio Workstation) software. You can edit time-related properties, such as the start or end
time of events directly in the event view. The detailed description of each graphical component are
as follows:

Figure 7.6: Event View

ID
Each track represents the audio content and the movements of an ID. The number of each ID is
displayed next to the ID color bar.

Mute / Solo Button
Like a DAW, you can temporarily mute a specific ID by clicking “M” (Mute) button or you can
mute all other tracks by clicking “S” (Solo) button. Muted buttons for manually muted tracks are
blue. Manually-muted tracks stay muted unless the ID solo is enabled. Manual mute is reapplied
when track solo is disabled. Mute buttons for tracks muted by soloed IDs are drawn in teal.

Record Button
If the record button of an ID or Group track is active, you can record sound paths by clicking and
dragging with the mouse on the dome view or sending OSC movement messages when Zirkonium
is started with the record transport button enabled. The resulting movements are automatically
created as events onto the armed IDs or Groups.

Time Zoom Slider
This slider controls the horizontal zoom factor of the event view.
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Track Zoom Slider
This slider controls the vertical zoom factor of the event view.

Waveform
Actual audio content of the associated source file.

Event Region
In the event view, events are represented as rectangles called event regions. On top of each event
region, a thumbnail, XY-Movement Lines, and a Jump Warning line are displayed.

Thumbnail A small snapshot image of the sound path
XY Movement - Span Lines The solid darker line displays the movement of the ID

on the X axis, the solid lighter line shows the movement of ID on Y axis. The
dotted line indicates the change in the span.

Jump Warning Line The red line at the left edge of each event region warns you
where the listener might perceive an unnatural abrupt sound movement (ie. jump)
due to a sudden change of ID position.

Visibility control
The visibility of each GUI component is configurable in the View -> Event View menu.

Waveforms show/hide the Waveform of a source file
Sound Paths show/hide lines that indicate the movement of the ID on X and Y axes
Thumbnails show/hide thumbnails of sound paths

Table 7.5: Event View Visibility Control

(Un)Muting & (Dis)Arming All IDs and/or Groups
Right-click on the event view’s track header on the left to show a context menu with the following
options for muting or arming multiple tracks:

• Mute IDs
• Unmute IDs
• Arm IDs & Groups
• Disarm IDs & Groups

R Mute and solo button states are saved with the project file.

7.3 Navigating the playback cursor
Zirkonium offers several ways to navigate the playback cursor.

7.3.1 Playback Cursor Position Field
The first option would be the Playback Cursor Position field. Simply set a time in h:mm:ss:cs
format and the green playback cursor will then jump to the provided time instantly.

7.3.2 Markers
You can easily jump to a specific point in time, using the “jump to previous marker” or “jump to
next marker” buttons in the transport bar.

The rewind button instantly sets the playback cursor position to beginning at 0:00:00:00.
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Figure 7.7: Navigating playback cursor with the playback cursor position field

Figure 7.8: Navigating playback cursor with the transport bar

7.3.3 Jump to playback Start Time

Figure 7.9: Playback start time is indicated with a thin dark green line in the Event View

When you start playback, Zirkonium automatically stores the time point that the playback
began. This time point is indicated with a vertical dark green line in the event view (Fig. 7.9).

After playback, if you want to hear the same part of your piece again, simply click the Jump to
playback start time button (or Command+R). The playback cursor will then jump immediately to
the position where the previous playback started.

7.3.4 Loop Playback

Zirkonium also offers a loop playback function, if you want to listen to a specific part of your piece
repeatedly. In order to specify the loop start and end time, use the loop start / end field to the right
of the Playback Cursor Position field.

You can enter the loop start / end times by typing time in either field in h:mm:ss:cs format or
by clicking the arrow button located next to each field to set the current time as the loop start or end
time. Additionally, the “I” (in) and “O” (out) key commands will set the loop start or end times
using the current time.

The loop start and end times are indicated with red lines in the event view.
Activate loop mode by clicking the Loop button so it becomes highlighted. To start looping

playback, press the Play button. To deactivate the loop mode, click the Loop button again.
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Figure 7.10: The transport bar with the activated loop button

Figure 7.11: The loop start/end time are displayed with thin red vertical lines

7.3.5 Time Ruler
There is a time ruler above the event view. You can click on the time ruler to adjust the position
of playback cursor. By double clicking, you can also start playback from the clicked position
immediately.

For instance, a common workflow to set the loop range might be: click on the time ruler to
move the cursor, set the loop start, click on the timer ruler to move the cursor again, set the loop
end.

Figure 7.12: Using Time Ruler for the navigation
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7.4 Creating an Event

Figure 7.13: Three types of events listed in the event table

As mentioned previously, Zirkonium handles three types of events: normal, initial, and marker.
Different steps are required to create each type.

7.4.1 Normal Event

Figure 7.14: Creating an event with the pen tool in the event view

There are two ways to create a normal event that controls the movement of an ID or a group.
You can create a new event by clicking the “+” button in the event tab of the table view, and select
an ID or a group as a target, using the pop-up menu in the Target column. Alternatively, you can
select the pen tool and draw a region in the event view to create an event for the associated ID or
group directly.

Figure 7.15: Shadow Regions

If you create a group event, the “shadow” region appears in the tracks of the member IDs of the
group. These shadow regions indicate that the movement of IDs are controlled by a group event.
For example, in figure 7.15, ID 1 and 3 are the member IDs of a group “Alpha”, thus the shadow
regions appear in the tracks of ID 1 and 3 above the group event.
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ID events for member IDs cannot be created or moved to overlap a group event in time (ie.
shadow region).

Auto Connect Events
Similar to ID creation, hold Opt/Alt when pressing the add event button (+) to automatically connect
the new event to the target ID of the previous event in the list and increment the start time. This
facilitates quick automation for creating multiple, subsequent events for the same ID.

7.4.2 Initial Event

Figure 7.16: Initial Events for each ID

As described in chapter 5, an initial event is automatically created when a new ID is added and
exists to assign a the IDs fixed initial position. This event is not removable from the event table and
cannot be assigned a sound path, however the initial position can be changed.

Initial events are automatically deleted, when the corresponding IDs are deleted.

7.4.3 Marker Event

Figure 7.17: Marker Events can be added directly

In order to create a marker event, select the “Event” tab in table view and click the “+” button.
An event with a “None” target appears in the event table. Change the target to “Marker” with the
pop-up menu under the “Target” column. The time is automatically set to the cursor position and
you can provide the newly created marker with a name.

Alternatively, you can click the time ruler above the event view with the Command key
pressed. Zirkonium then creates a marker event automatically at the clicked position and names it
“newMarker”. The name is then modifiable in the event table.

7.4.4 Auto Event Creation
The creation of events for each sound is can be tedious work. Zirkonium offers a way to create
events automatically based on the amplitude envelope of the loaded audio data.

To use this functionality, load at least one sound file to the source table, create at least one ID
in the ID table, and select (Edit -> Auto-Event Creation) from the menu, then the Auto Event
Creation Sheet will appear on the window (Fig. 7.19).

The Auto Event Creation (AEC) algorithm analyzes the amplitude envelope of the target file
by calculating the RMS (Root Means Square) of audio sample blocks. If the algorithm finds a
block whose RMS value exceeds the provided threshold, the algorithm creates a new event. It
then attempts to find the end of the event by finding successive blocks whose RMS values are
continuously below the threshold.

The sheet consists of the following components:
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Figure 7.18: Events automatically created by Auto Event Creation

Source Selector Pop-up Button

Destination Pop-up Button

Range fields

Source Channel

Figure 7.19: Auto Event Creation Sheet

Source Selector Pop-up Button
The target source file that the AEC algorithm will analyze. The small pop-up button next to this
one is the channel selector.

Destination Pop-up Button
The destination ID or group that the automatically created events will be placed into.

R The destination of the analysis is not limited to its source, this means you can easily create a
spatial interaction between two sound sources. For example, when one sound source rings,
the other sound source moves. Furthermore, you can select a sound source that is not assigned
to an ID, therefore, you can create a series of events based on audio that the audience will
never listen to.

Range fields
The algorithm checks the amplitude envelope in the time range defined by "from" and "to" text
fields in h:mm:ss:cs format.
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You can also specify the time range by using the pop-up buttons which include project start and
end times and using marker time positions. Additionally, click the "Loop range" button to apply the
loop range times defined in the main window.

Analysis Parameters
Block Size This pop-up determines the number of samples for RMS analysis. For a percussive

sound, a small block size tends to produce better results.
Threshold The threshold parameter for the algorithm in decibels between -100 and 0. The default

threshold is -50 dB. For a recording with a recognizable background noise, set a higher
threshold.

Hold The hold value sets the duration of silence that the algorithm requires to determine the end
of the event. The algorithm may determine the end of an event based on silence in the sound
file. However, for example, a phrase played by a percussion instrument may contain a large
number of short silences between each attack. In this case, the algorithm may yield a large
number of events. In order to avoid this, set a higher hold parameter. In the figure 7.20 shows
the difference of created events resulting from different hold values.

a)

b)

c)

Figure 7.20: Different hold parameters and their results a) sample b) hold = 0.1 s c) hold = 0.5 s
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7.5 Editing Time-related Event Properties

You can edit time-related event properties, such as start time or end time in three different interfaces:
Event View, Event Table, and the Quick Event Manipulator. Zirkonium also provides an event
selection panel, which facilitates to select multiple events at once.

R Zirkonium strictly forbids the overlap of multiple events belonging to the same ID or group.
If you try to create or move an event on top of another, the software disallows the change and
automatically reverts the modified properties of the event(s). For instance, dragging an event
region over another in the event view will return the event to it’s original times.

7.5.1 Event View

Shifting Events

Figure 7.21: Shift Event

In the event view, you can move the event region by simply dragging the region with the mouse
when using the select tool. To nudge the currently selected events or the current time by a small
amount, press the left or right arrow keys. Hold Opt/Alt to "jump" which increases the amount by
10.

Scaling Events

Figure 7.22: Scale Cursor

If you hover your mouse cursor over the left or right edge of an event region, the arrow cursor
becomes a scale cursor. This indicates that the region is scalable when you click and drag the edge.

Copying Events

To copy events, press the Opt/Alt key and drag the target region(s) to a new location. A copy is
created when the mouse button is released, unless an overlap is detected.

It is also possible to shift, scale, or copy multiple events simultaneously, simply select multiple
events with Shift + click. The operation will be canceled if one of the modified events overlaps
with other unselected events.
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7.5.2 Event Table
You can edit the start time and end time of events directly in the event table under the Start and End
column by double-clicking the cells. The provided time should be positive and in the h:mm:ss:cs
format. If you set the end time later than the project duration, the overall duration will be automati-
cally updated.

Figure 7.23: Event Name displayed in the dome view

You can name events in the event table. If you give an event a name, it will appear in the Dome
View next to the triangle start symbol (fig:7.23).

7.5.3 Quick Manipulator
Beneath the table view, there is a set of pop-up buttons and text fields. This is called the Quick
Event Manipulator. You can use it to shift, scale, or copy multiple selected events precisely.

R If any overlaps are detected, the action will be cancelled.

The Quick Manipulator offers three modes which can be selected with the leftmost pop-up
button.

Shift mode
In Shift mode, you can shift the start time and/or end time of the selected events.

With the shift target pop-up button, you can select the target of the shift operation: start time,
end time, or both start and end time. Enter the direction of the operation with the direction pop-up,
input the amount of shift time in the shift time field, and press Apply to execute the operation.

Figure 7.24: Shift Mode

Scale mode
In Scale mode, you can scale the duration of the selected events. To perform this operation, simply
select the direction of scaling, input scale factor in percentage, and press the Apply button.

Copy mode
In Copy mode, you can copy the selected events to the specified time. Simply enter the target time
in the text field and press Apply.
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Figure 7.25: Scale Mode

Figure 7.26: Copy Mode

7.5.4 Event Selection Sheet

Your project may consist of a large number of spatial events, and it may sometimes be cumbersome
to select multiple events you want to modify in the event view or event table.

Zirkonium can help you to select specific events that match certain conditions. In order to
activate this functionality, open the Event Selection Sheet from the Edit menu: Edit -> Select
Events... menu (fig7.27).

Figure 7.27: Event Selection Sheet

Target(s) Table
Select target IDs or groups for filtering in the table. You can select multiple targets with Shift +
click.

Target Time Property Pop-up
Select the target time property for filtering events: “Start” and “End”.

Direction Pop-up
Choose the direction of event filtering: “before”, “after”, and “equals to”.

Marker Pop-up - Time Field
Enter a time for filtering in h:mm:ss:cs format in the time field. Alternatively, select a marker event
using the marker pop-up button, in which case the time field will be automatically filled with the
start time of the selected marker and become uneditable.
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Add/Remove Button
Press these buttons to add or remove a filter condition.

If all parameters for filtering are set, press the “Apply” button to execute filtering. The sheet
will close and all events that match the provided conditions will be automatically selected in the
event table and event view.

7.6 Editing Space-Related Event Properties

With the Dome View and Motion View, you can manipulate space-related properties of events that
determine the actual position of IDs over the course of an event. In Dome view, you can draw a
sound path, a path that an ID moves along. By default, an ID moves from one end to the other end
of the sound path (from the triangle to the cross symbol) at a constant speed. However, you can
accelerate or decelerate the movement of an ID using the Motion View motion path.

7.6.1 Dome View
Creating a Sound Path
In Zirkonium, there are three ways to create a sound path: manually, algorithmically, or movement
recording. With the Pen tool selected, draw a path manually using Bézier curves by using mouse
clicks. To let the software draw curves for you, you can use the “Add Circle or Spiral” popover.
Last, you can record the mouse motion in real-time on the Dome View with the live drawing feature.

-Using the Pen Tool
Select a single spatial event and click the pen tool at the top right corner of the window. Next, click
in the dome view. The first click creates the start position of the sound path. The second click
creates an end position of the sound path. These two positions are marked with “triangle” and
“cross” symbols respectively (fig:7.28).

Figure 7.28: Triangle and Cross symbols

If you add more points to the path by clicking the dome view, the path will be extended and the
end position of the path moves to the newest point added.

To bend the curve while creating adding a point, you can click on the dome view then drag the
mouse cursor. The curve will be set when the mouse is released.

-Using Select Tool
Click the select tool in the top right corner of the window. When select mode is enabled, the anchor
points in the path can be moved and the curve between points adjusted using the Bézier handles.

To select multiple anchor points for editing, drag-select by clicking outside of the curve, then
dragging the select region to cover the desired points and release the mouse button. Selected points
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are drawn in red. Click on an empty space in the dome view or press Escape to clear the current
selection.

-Using the “Add Circle or Spiral” popover
It’s not easy to draw a perfect circle or spiral with Bézier curves, but Zirkonium offers a utility
function that facilitates the creation of a circle and spiral-shaped sound paths. To activate this
function, select an event, right click on the dome view, then choose “Add Circle or Spiral” from the
context menu to open the Add Circle or Spiral popover.

The circle or spiral drawing algorithm can either create a new path in an empty event or append
to an existing path. In which case of an empty event, the start azimuth and elevation can be entered
manually. For an instantaneous event (point) or trajectory event (path), the last point in the current
path is used as the starting azimuth and elevation values for the algorithm.

In the popover, input the following four parameters that determine the properties of the resulting
circle or a spiral and press the Add button. You can also navigate between fields with the Tab key
and activate the Add button with the Return key.

Figure 7.29: add circle/spiral popover

Azimuth Start the azimuth origin
Azimuth End / Delta Rotation the amount of rotation to add in full circles (360°)

1 represents one full circle clockwise
-1 represents one full circle counterclockwise

Elevation Start the elevation origin
Elevation End / Delta Elevation the amount of elevation change too add in degrees

20 = elevate 20 degrees toward the center (90°)
-20 = descend 20 degrees toward the floor (0°)

Table 7.6: Parameters of Add Circle / Spiral Popover

Creating a Sound Path
-Adding Individual Points
In Pen Mode is enabled, simply click on the dome view to add points to a path. The initial click
will create the starting position of the event.

-Using Live Drawing
"Live drawing" refers to creating a soundpath via a gestural movement as opposed to creating
individual points one by one. This feature can be used to create a path on a single selected event or
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create multiple event paths over time as the project plays.
In Pen mode with an event selected, hold Opt/Alt while dragging to automatically add anchor

points using a mouse gesture. This works well for creating complex and/or quick movements, for
example, which do not require precise positioning.

To record mouse motion to events, activate the “R”-button7.2.4 of an ID or group track in the
event view, enable the Record transport button, start playback, and draw by clicking and dragging
on the dome view. When the mouse button is released, the gesture will be recorded. When playback
is stopped, the gestures will be converted into events associated with the armed IDs or groups.

By default, if there is an overlap with an existing event, the recorded event is dropped. To allow
overwriting of existing events, enable the "Overwrite Events" option in the Edit -> Recording
submenu.

To have Zirkonium automatically set the Béezier curve handles based on the position between
anchor points while drawing, enable the "Smooth Paths" option in the Edit -> Dome View submenu
for automatic path smoothing. This results in a "smoothed" path as opposed to strait lines between
anchor points. For the same feature while recording live drawing to events, enable "Smooth Event
Paths" in Edit -> Recording.

Editing a Sound Path
-Moving Anchor Points
To move an anchor point, click and drag the anchor point while in select mode. Also, double-click
on a section of the curve to add a new anchor point between existing points.

Anchor points can also be "snapped" to the background grid or to the closest speaker by
enabling the related option in the Edit -> Dome View submenu, either “Snap to Grid” or “Snap to
Speaker” respectively.

-Bending a Sound Path

Figure 7.30: Bezier Handles

To bend an existing sound path, use the select tool and drag one of the two Bézier control
handles (fig:7.30) that emerge from the associated anchor point. By default, the position of one
control handle will also be mirrored by the second. Hold Shift while dragging a handle to adjust it
individually. To reset a control handle by moving it back to the anchor point, click the handle with
the Opt/Alt key pressed.

The curve handles placed directly on the anchor point can be expanded by double-clicking on
the anchor point. Double-clicking on an anchor point with extended curve handles will reset them,
effectively straightening that part of the sound curve. Additionally, you can click on the anchor
point while holding Shift and drag out a single handle.
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Figure 7.31: Bending one side with Shift + drag

-Applying Affine Transformation to a Sound Path
With the affine tool, you can translate, rotate, or scale the entire sound path drawn in the dome view.
In order to apply these operations, select the affine tool beneath the pen tool. A bounding box with
9 small black handles, called affine handles, will appears around the current path.

To translate the path, drag the handle in the middle. To rotate the path, hold the Opt/Alt key
and drag a corner of the bounding box. To scale the path, drag one of the 8 black affine handles
surrounding the path. Dragging from a corner point will resize while keeping the aspect ratio unless
the Shift key is pressed.

You can select and apply the same transformation to multiple events. For instance, selecting all
events in the Event List (via Command+A) allows for essentially editing the entire project with the
transform tool and/or popover.

Those actions can also be done more precisely via the transform popover. Right-click in the
Dome View to access the context menu and choose Transform Path to open the popover. You can
select one or multiple events before opening the menu, so the actions will be applied to all selected
events. Available actions are:

• Rotate -360 to 360 degrees
• Translate -1 to 1
• Scale with a factor of 0.01 to 4.0
The transform is applied when releasing the mouse. To cancel a transform edit, for example

while dragging or rotating, press the Escape key.

-Smooth or Straighten the a Sound Path
Right-click on the dome view when a single event is selected and choose "Smooth Path" in the
context menu. This will calculate new control handle positions for each curve segment in order to
smooth the overall path.

Conversely, choosing "Straighten Path" in the context menu will reset the control handle
positions for each curve segment back to it’s anchor point. This will effectively reset each Bézier
curve to a straight line.

R If there are anchor points selected, smoothing or handle reset will be applied to the selected
curve segments only.

-Snapping start or end position of a Sound Path
During playback, an ID instantly jumps to the start position of the sound path without any interpo-
lation, when the playback cursor reaches the start time of a certain event, unless the end position
of the previous event perfectly matches the start position of the current event, this will cause an
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Figure 7.32: Affine handles and their functions

Figure 7.33: Incontinuity of sound paths

abrupt change of ID position or “jump” at the beginning of an event that may cause unnatural
auditory incontinuity, especially if an audible signal is played by the spatial rendering algorithm
at the moment of the “jump”. Zirkonium automatically finds these “jumps” and indicates them
with red lines (called the Jump Warning Line) at the left edge of event regions in the event view
(fig7.33).

There are four solutions to avoid this problem:
1. Move the start position of the current event to the end position of the previous event
2. Move the end position of the previous event to the start position of the current event
3. Create an event between the current and previous event for interpolating the start position of

the current event and the end position of the previous event
4. Start the event at the moment when the source (sound file or live input) is silent

Zirkonium is capable of performing solutions 1 to 3 automatically. To move the start position of the
current event to the end position of the previous event, press the “Snap to Cross” button (fig:7.34)
above the Camera Position Reset Button.

To move the end position of the previous event to the start position of the current event. Select
the previous event in the event table or event view and press the “Snap to Triangle” button (fig:7.35).

To create an interpolation event, simply create an event between the current and previous events
with the pen tool. The newly created event will be automatically filled with a two point (single
line) sound path that interpolates the start position of the current event and the end position of the
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Figure 7.34: Snap To Cross

Figure 7.35: Snap To Triangle

previous event (fig:7.36).

-Moving the Camera position
You can move the camera position vertically by rotating your mouse wheel and horizontally by Shift
+ mouse wheel. Zooming in/out is also possible by Command + mouse wheel and Command+plus /
Command+minus. Alternatively, hold Command while scrolling or use the touch pad pinch gesture.
Press Command+0 or click the Camera Position Reset Button above the sliders on the right side of
the window to reset the camera position.

-Deleting a part of a sound Path
To delete specific parts of a sound path, drag-select the desire points and press Delete.

-Deleting entire sound path
To delete a sound path in the dome view, simply click on the “Trash” button located near the right
bottom corner of the Dome View. Alternatively, switch to select mode, drag-select all anchor points,
then press the Delete key.

7.6.2 Motion View
You can control the expansion of sound diffusion (span), movement of an ID along the defined
sound path, and gain over course of the event with the Motion View.

A span path, motion path, and gain path are automatically created with an event. The motion
view becomes editable when at least one anchor point is added to the dome view, ie. Instantaneous
or Trajectory event. For events with a single point (Instantaneous), only the initial values in the
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Figure 7.36: Interpolation Event

Figure 7.37: Zoomed Dome View with shifted camera position

span, motion, and gain paths are used.
The span and gain paths map their respective values on the Y-axis and begin with set values for

event start and end. The motion path defines the position of an ID along the sound path during the
time frame of an event. By default, the motion path moves the ID or group from the start position
(triangle symbol) to the end position (cross symbol) in a constant speed.

Switching span, motion, and gain mode
By clicking the span / motion / gain buttons located at the right of the motion view, you can
change the current path for display and editing (fig7.39).

Editing a motion view path
The motion view paths are simple 2 dimensional curves over the event time on the X-axis. Each
curve begins with a minimum of start and end points which can be reset but not deleted.

-Moving anchor points
In select mode, hover over a black start or end anchor point, click, then drag on Y-axis to change
the value. Gray anchor points cannot be changed. The start and end points cannot be moved on the
X-axis.

R The motion path must always end at the last point along the sound path, therefore the final
motion path point is fixed. The span and gain paths do not have this limitation.
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Figure 7.38: Selecting certain anchor points

Figure 7.39: In Span Mode (Left) / In Motion Mode (Center) / In Gain Mode (Right)

-Bending curves

To bend a path in the motion view, hover the mouse cursor on the motion path with the arrow tool
and the cursor will become an open-hand. Then, simply click the curve and drag it up or down to
bend it.

Figure 7.40: Bending a Motion View Path

-Adding anchor points

As previously note, the time (X-axis) of the start and end anchor points can not be moved. However,
you can add extra anchor points in the motion view by clicking the view with the pen tool (fig:7.42).

In select mode, these additional anchor points can be moved on both the X and Y-axes by
clicking and dragging.

-Add a Precise Point in the Motion View

In Pen Mode, clicking in the Motion View will add a point to the path being currently edited.
Right-clicking will open a context menu to access the “Add/Edit Point” popover to set an exact time
(X-axis) and value (Y-axis). If the right-click occurs over an existing point, the point’s position can
be edited.
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-Selecting Motion View Anchor Points
As with the dome view, multiple anchor points on the motion view can be drag-selected in select
mode. Selected points are drawn in red (fig7.41). Clicking outside of the curve or pressing Escape
clears the current selection.

Figure 7.41: Region Selection in Motion View

-Straighten the Selected Motion View Path
Right-click and choose "Straighten Path" in the context-menu to reset the curves for the selected
anchor points to straight lines. Also, double-click on an anchor point to straighten the next curve.

Figure 7.42: A Motion Path with multiple anchor points

-Adjusting the position of audio content to be played
By using both the Dome View and Motion View, you can adjust the position of audio content
without changing the shape of the sound path. Here is an example:

In figure 7.43-left, a one-second sound sample is spatialized. In this setting, the loudest part
will be played mainly on speaker 20 if the motion view is not edited at all.

In the case that you want the loudest part of the sample to be played from speaker 21, add one
more anchor point on the dome view and placed in the middle of the sound path on top of speaker
21. The added anchor point is also displayed in the vertical Mini-Sound Path at the left side of the
motion view when in motion mode (fig:7.43-center).

Now add an anchor point to the motion path in the motion view and place it at the loudest
moment in the waveform and anchor point at the vertical mini-sound path. This means that
ID reaches the anchor point on the Mini-Sound path (i.e. speaker 21) at the loudest moment
(fig:7.43-right).

In this way, you can manipulate flexibly the relationship between the position in Dome View
and the source audio content.

-Deleting part of a motion view path
To delete the added anchor points for a path in the motion view, drag-select multiple anchor points
in select mode and press the Delete key. Start and end anchor points cannot be deleted.

Deleting span, motion, and gain paths
To reset all motion view paths at once, simply click on the “Trash” button located at the right
bottom corner of the Motion View.

To delete only a single path, drag-select and delete all points in the motion view. The start and
end points will remain.
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Figure 7.43: Adjusting audio content and position





8. Exporting Projects

In order to improve compatibility and realize long-term storage, Zirkonium offers various exporting
functionalities: Bounce and Archive. This chapter describes each function.

8.1 Bounce
The Bounce function allows you to record all audio signals sent to the virtual loudspeakers and
store them in separate sound files.

In order to activate the bounce function, select File->Bounce. A save panel will appear. Select
the destination folder, filename prefix for the bounced file(s), and click the "Bounce" button. The
modal "Bouncing to" sheet will then appear on the window (Fig. 8.1) as long as recording is in
progress. To interrupt the bounce, press the "Cancel" button or press the Escape key.

Figure 8.1: Bouncing to modal sheet

The bounce function does not create a new folder automatically for the bounced files, but saves
to the selected destination folder, by default the parent folder of the current project file.

The output format is 24 bit WAV files. Output files will be numbered 1 to n virtual speaker
channels based on the currently loaded speaker setup: “FILENAME #.wav” (Fig. 8.2). If the HRTF
"headphone mode" button is enabled, output will be rendered via HRTF into a single stereo file:
“FILENAME hrtf.wav”.

R Note: Exisiting audio files will be overwritten.
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Figure 8.2: Bounced files are automatically suffixed

8.1.1 Bouncing Spatialized Versions
As the bounce function saves based on the current speaker setup, different spatialzed versions of
the same piece can be exported. For instance, if the speaker layout for a target system is known,
create/load an equivalent setup and bounce to audio files. Playback the "baked" version of the
project using the exported files in a DAW or multichannel playback system with each channel
correspoding the respectve speaker.

8.1.2 Bounce Options
By default, the bounce function is performed in real time with both source file and live inputs
over the duration of the piece. To modify bounce behavior, utilize the additional bounce options
presented as checkboxes in the Bounce save panel.

These values are persistent and saved with the user account.

Bounce Offline

When enabled, bouncing will be performed faster than real time, however live inputs will not be
recorded. This speeds up exports for source file-only projects. Disbaled by default.

Update UI

When enabled, the main UI (dome view, event view, etc) will be updated as the piece progresses. If
not bouncing in real time this will save some CPU for large projects. Enabled by default.

Wait for Sync

When enabled, bouncing will wait until triggered to begin: via MIDI Clock, MIDI Timecode, or an
OSC play message. This allows for real time bounces which need to be triggered externally, for
instance when live audio is being generated by external software. Disabled by default.
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8.2 Archiving
You can import multiple sound files located at different folders on your disk system which are
stored internally as absolute paths. On project load, Zirkonium first searches for files of the same
name in the project’s parent folder, then falls back to the absolute path.

In case you want to copy your piece to another computer, you may need to gather all your
sound files scattered in your disk system and make a package that contains all data required to
reconstruct the piece in another environment. Zirkonium offers a function to automatically execute
this "consolidatiin" process. First, save your current project and select File->Archive Project. A
modal save panel will open, select a destination folder, and click the "Archive" button.

Original Zirkonium File

Generated
archive folder

project file for archive copied sound files

Figure 8.3: An example of an archived project

Zirkonium will then create a new folder under the folder where the Zirkonium file is located
and name it project name_archive. Then, copies of all sound files used in the project, as well as
the Zirkonium project file itself, are saved to this folder (Fig. 8.3. The ".zirk" file is automatically
suffixed with "_archive."

You can now compress the archive folder and copy it to another machine or disk system.





9. Other functionalities

This chapter briefly introduces further functionalities of Zirkonium.

9.1 Auto Versioning
Zirkonium does not currently have undo or redo support but provides a simple feature called “Auto
Versioning” to facilitate project file backup creation.

Select it in the File -> Auto Versioning menu item.
When enabled, Zirkonium will save a timestamped copy of the project file whenever the project

is saved in the format:“FILE.yyyy-MM-DD_HHmmss.EXT”. If you open one of the timestamped
versions and save, the “original” project file will be updated, so it will always be up to date with the
latest version. Timestamped copes are saved in the same folder as the original file.

Figure 9.1: Auto Versioning Files

This process is relatively simple, so please keep the following points in mind:
• For versions to stay in sync with the original project, they must be in the same folder and

they must have the same root name.
• If you open a previous version and save, the original project is updated and a new version is

created, however the existing version is not changed.
• There are no timezone or existing file checks.

9.2 Importing MK1
To import a Zirkonium project file created with Zirkonium MK1 "Classic", select File->Import
MK1 File. This imports all IDs and group properties as well as their associated events which are
appended to those in the current project. For a clean start, create a new project then import.
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R This feature is currently experimental (at best) and does not yet support all aspects of MK1
projects, namely MK1 delta movements are rendered into MK3 trajectory paths. As of writing,
development on this is ongoing toward the next version of Zirkonium.

9.3 Controlling with OSC
The position and span of each ID can be controlled by other applications, such as Max, Pure Data,
or SuperCollider via OSC (Open Sound Control) networking messages. Additionally, position,
transport, and timing messages can be sent from Zirkonium to external software.

There are global network preferences for the OSC receiver and senders on the Zirkonium3 ->
Settings -> Network tab. These preferences configure the internal receiver for OSC messages sent
by external software. Additionally, multiple senders can be added for external target addresses and
message types. Zirkonium supports multiple senders but only one receiver.

Project-specific settings such as sender address patterns and value mappings are accessible at
File -> Project Settings -> Network Settings (Fig. 9.2). These settings configure how real-time
data sent as OSC messages are formatted for external software.

Figure 9.2: Global Network Preferences and Project Settings

9.3.1 OSC Receiver
The OSC Receiver tab (Fig. 9.3) in the global network settings configures the internal OSC receiver.
“Enable” check box when this check box is checked, Zirkonium accepts incoming OSC messages
Port Network port used for receiving OSC messages, default 50000
OSC Receiver Message Patterns Supported OSC message specification

9.3.2 OSC Senders
The OSC Senders tab in the global network preferences configures the internal OSC senders.

OSC Sender table
The table shows the currently active OSC senders. You can configure the following parameters for
each sender:
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Figure 9.3: OSC Receiver Tab

IP address Target host IP address
port Target host port, default 50001
Time If checked, the time message will be sent
ID Pos XY If checked, the Cartesian position of each ID will be sent
ID Pos AE If checked, the Polar azimuth and elevation of each ID will be sent
ID Spn If checked, the span of each ID will be sent
ID Gain RMS If checked, the current gain RMS of each ID will be sent
ID Gain dB If checked, the current gain in dB of each ID will be sent
Transport If checked, transport control messages will be sent (play, pause, etc)
ZirkPad If checked, Zirkonium sends live ID and speaker levels to ZirkPad

IP address and port fields become editable when double-clicked.

Add Sender
You can add a new sender by entering an IP address and Port number in the fields next to “Add
Sender to Address” and clicking the “+” button.

9.3.3 OSC Message Formatting
In the project network settings, the format for real-time message sending can be set on a per-project
basis to work with different external software.

R In order to send values of an ID, the algorithm of that ID has to be set to “OSC“ in the main
interface IDs table.

OSC Sender Address Patterns
These fields determine the OSC address pattern of the ID position, ID span, ID gain, and time
messages. By default, the ID index is sent as the first argument for position, span, and gain
messages. In order to insert the index within the address pattern, use the ‘@{id}‘ string: for
example, "/id/@{id}/span" -> "/id/1/span 0.1", "/id/2/span 0.2", etc. In this case, the first argument
of the message will be the actual message value such as X position, span value, or gain value.
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OSC Sender Value Mappings
The value mappings allow to scale the values of an ID span to a range with specified minimum and
maximum. The range can be inverted by setting a minimum below the maximum.

Presets
Zirkonium provides a small set of message format presets available via the buttons in the Presets
box:

Default current Zirkonium default, ID indices as first argument
Zirkonium 3.4 original Zirkonium 3.4 pattern, ID indices embedded within message address

Panoramix mapping for Zirkonium IDs to Panoramix tracks (see 9.3.3)
These can be selected in the preset section of the project network settings sheet. One of them

is the Panoramix preset, that helps controlling the IRCAM Panoramix over OSC by mapping
Zirkonium IDs to Panoramix tracks

Panoramix Control
Panoramix is a “post-production workstation for 3D-audio contents” and spatialization engine from
IRCAM which can be controlled over OSC. Zirkonium IDs can be configured for basic control
of Panoramix tracks via “/track/@{id}/*” address patterns. For example, to control the Cartesian
position: “/track/@{id}/xy”.

https://www.ircam.fr/recherche/equipes-recherche/eac/panoramix/

9.4 Syncing with other software
Zirkonium is able to synchronize playback with other audio software, such as Logic, Ableton Live
or Max, by receiving MIDI Clock, MIDI Time Code, or OSC messages.

9.4.1 Sync Mode
You can select a mode for clock synchronization in the global sync settings: Zirkonium3 ->
Settings Sync tab.

Internal
Uses internal clock and does not sync externally.

MIDI Time Code
Accepts MTC messages from other software and adjusts current time. If this mode is selected, play
button will be disabled.

MIDI Clock
Accepts MIDI Clock messages from other software and adjusts current time. If this mode is
selected, play button will be disabled.

9.4.2 MIDI
Some software sends MIDI Time Code with an offset by default. Set the “MTC offset” field to
adjust the base tine for received MTC messages. For example, Logic sends current time + 1 hour,
so set the offset to “1:00:00.00”.

9.4.3 OSC
For syncing via OSC, the external software can send transport messages: “
play”, “
pause”, and “
time” See the OSC Receiver global network settings tab for details (Fig. 9.3).

https://www.ircam.fr/recherche/equipes-recherche/eac/panoramix/
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Figure 9.4: Sync Mode pop-up button beneath the Transport Bar

R It it advised not to send Zirkonium both transport OSC and MIDI sync messages at the same
time. This can cause potential timing instability.

9.5 DAW piping
Zirkonium was originally designed for spatializing pre-rendered multi-channel pieces, however
it can be used within a real-time chain of other audio software. Many composers combine Zirko-
nium, "audio piping" software such as Black Hole or SoundFlower (historical), and OSC / MIDI
sync messages in order to send not only control messages but also audio streams from a DAW
environment, such as Ableton Live. In this way, the user is able to utilize Zirkonium solely as a
spatialization engine or "renderer" while utilizing the DAW for live editing or effects (Fig. 9.5).

DAW Zirkonium

OSC

Audio
(Sound Flower)

Figure 9.5: DAW-based spatialization system, using Zirkonium as the renderer

9.6 Customizing the Spatialization Server

R This section is intended for advanced Pd users. If you are not familiar with Pd and would
like to modify/customize the spatialization algorithms of Zirkonium. Please refer to the Pd
website http://puredata.info.

http://puredata.info
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9.6.1 How Zirkonium realizes spatial rendering
Zirkonium internally utilizes Pure Data as the audio processing engine, and this core functionality
is integrated in the Zirkonium application, employing libpd.

You are able to access the Zirkonium Spatialization Server, a Pd patch and set of abstractions
that read given sound files and process spatialization algorithms on their associated channels
through virtual speaker outputs, and customize it AT YOUR OWN RISK.

9.6.2 Accessing the Zirkonium Server Patch
In order to access the Zirkonium Server Patch, right click on the Zirkonium3 application icon
and choose “Show Package Contents”[Fig:9.6]. You will find the core Pd patch named “zirko-
nium_server.pd” as well as a few abstractions and external objects in the Contents/Resources/pd
folder.

Figure 9.6: Location of Zirkonium Server

9.6.3 Zirkonium Spatialization Server on Github
Additionally, the spatialization server can be found separate from the Zirkonium application in a
public Github repository:

https://github.com/zkmkarlsruhe/ZirkoniumSpatializationServer
The server can be controlled for playback by manually sending mapping and setup messages,

the same that the application GUI sends internally. The various abstractions are documented via
help patches, such as “zirk_id-help.pd” for the individual ID layer.

https://github.com/zkmkarlsruhe/ZirkoniumSpatializationServer


10. Appendix 1: SpeakerSetup

SpeakerSetup is a macOS application that enables you to set up your own non-standardized
loudspeaker configurations. The application lets you graphically organize the speakers and export
the configuration as a XML file. The exported XML can then be loaded in Zirkonium3.

10.1 Installation, System Requirements
SpeakerSetup is included with Zirkonium download and can be installed by copying the Zirkonium3
folder to your Applications folder. Alternatively, the SpeakerSetup can be copied by itself. The
application runs on macOS 10.12 or later.

10.2 GUI Overview
10.2.1 3D overview

This view shows a listener, surrounded by speakers, in a 3D space. You can change the camera
position by dragging the view and zooming in/out by rotating the mouse wheel or two-finger
trackpad scrolling.

In the view, each speaker is indicated as a colored cube. The speaker that is furthest from the
sweet-spot is indicated with a darker color than the other speakers. This speaker is used as the
reference speaker for calculating the delay compensation.

The black numbers above the speakers indicate the index number of each speaker, and the
brown numbers below the speakers are the numbers of the associated audio hardware outputs.

10.2.2 Camera buttons
By these buttons, you can move the camera in the 3D overview to a specific position.

10.2.3 Dimensionality pop-up
You can define the dimensionality of your speaker setup. 2D means all speakers are positioned at
the same height (ear level). If you select 2D, the z and elevation values of all speakers are set to 0
and become uneditable.
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Figure 10.1: SpeakerSetup
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10.2.4 Measurement system pop-up
In the speaker setup, you can define the position of speakers either with metric values or relative
values from -1 to 1. This pop-up allows you to select a mode from these two options. This pop-up
button will be disabled when you add the first speaker to the view. To enable this pop-up button
again, delete the all speakers in the view.

R In case you select the relative mode, Speaker Setup will not output XML attributes for delay
compensation.

10.2.5 Delay Compensation Check Box
This check box enables or disables the calculation of delay compensation based on metric distances
between the speakers and the sweet-spot.

10.2.6 Import / Export button
These buttons let you export and import XML data that contains a loudspeaker configuration.

10.2.7 Speaker table
This table lists all the speakers in the 3D overview. If you select a speaker in the list, a black line
appears in the 3D overview to indicate the selected speaker.

You can delete the speaker by selecting a speaker and pressing the delete key.
The following is a description of each column of the table

#
Index number of each speaker. The number must be unique.

ring
The ring (i.e. speaker group) that the speaker belongs to. You can choose from ring 1 to 10.

x,y,z
The position of the speaker in Cartesian coordinates. When you change one of these values, the
value of azimuth, elevation, and distance will be automatically recalculated.

azimuth, elevation, distance
The position of the speaker in spherical coordinates. When you change one of these values, the
value of x, y, and z will be automatically recalculated.

Output
The audio hardware output channel assigned to the speaker.

10.2.8 Speaker filter
With this pop-up button, you can filter speakers shown in the table by the ring index. This function
is particularly useful when you want to focus on a small group of speakers.

10.2.9 Clear All button
Clear all speakers in the scene.

10.2.10 “+” button
Add a new speaker to the scene.
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Adopting the convention of the first version of Zirkonium, Speaker Setup adds the first speaker
right behind the listener and gives it the index number 1. Then, it labels adjacent speakers
counterclockwise by default. You are not obliged to follow this convention. If you prefer another
numbering convention, feel free to change the speaker index number.

Ensure, however, that the numbering scheme used in each ring rotates consecutively around
the center and does not jump back and forth across the space. Also, rings are best numbered
starting with the largest, outer ring as number 1 and progressing inwards to numbers 2, r, and so
on.

10.2.11 Speaker Property Editor
In this pane, all properties of the selected speaker are displayed and the values are adjustable with
either sliders or text boxes.

If the relative measurement system is selected, and delay compensation is activated, two
additional parameters are displayed at the bottom of this pane.

Time to Sweetspot
Based on the provided data of speaker position, the software calculates automatically the approxi-
mate time it takes the sound to travel from the selected speaker to the sweet-spot. The speed of
sound is predefined as 340 meters/sec. If the relative measurement system is selected, this field will
be hidden.

Delay Compensation
Delay compensation time based on the metrical position of each speaker. If the relative measurement
system is selected or the delay compensation in unchecked, this field will be hidden.

If the distance between the sweet-spot and all speakers is not same, the sound generated by
nearer speakers from the sweet-spot reach the sweet-spot earlier than speakers that are further
away. This may cause an unintended Haas effect and possibly alter the sound quality. In order to
avoid this problem, Zirkonium is able to apply a slight delay to the signal fed to nearer speakers.
This is called delay compensation. According to the provided metric distances of speakers,
Speaker Setup automatically calculates the appropriate delay time for each speaker and stores
them in the XML file.

R In the absolute mode, the range of x, y, z position sliders in the property editor is limited
from -25 to 25 (meters). If you want to setup loudspeakers for a larger space, please type the
number directly in the text box.

10.3 Typical Setup procedure

The following is an example of a typical speaker setup creation procedure:
1. Define the dimensionality of your speaker setup with the dimensionality pop-up. If the

vertical position (i.e. the distance between the speaker cone and the floor) of all your speakers
in your room is equal, select 2D, if not, select 3D.

2. Select mode from absolute or relative with the measurement system pop-up. If the data
of distances between sweet-spot and each speaker is at hand, select absolute mode. If the
distance between the sweet spot and each speaker is not always equal, it is advised to choose
absolute mode and measure the distance between the sweet-spot and the speakers.

3. Add an arbitrary number of speakers by clicking the “+” button several times.
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4. If you want to categorize the added speakers into groups, use the “Ring” pop-up menu in the
speaker table and assign a new ring index to each speaker. You can filter the list by these ring
indexes, using the speaker filter pop-up.

5. Select the created speakers one by one and enter the position of each speaker, using the
sliders or the text field in the property editor.

6. When you finish with the setup, click the “Export” button, name the XML file, and click the
save button.

The new XML file can now be loaded into Zirkonium via File -> Load Speaker Setup -> Load
from XML File....

Additionally, the “Import“ button can be used to load an existing XML file as a basis for
creating a new version.





11. Appendix 2: ZirkVideoPlayer

ZirkVideoPlayer is a simple Quicktime player that accepts OSC messages, MIDI Timecode, or
MIDI Clock for playback. This enables you to synchronize a video and a soundtrack that is
spatialized with Zirkonium or other external software.

11.1 Installation, System Requirements

ZirkVideoPlayer is included with Zirkonium download and can be installed by copying the Zirko-
nium3 folder to your Applications folder. Alternatively, the video player can be copied by itself.
The application runs on macOS 10.13 or later.

11.2 Opening a File

To open a file, select “open” from the file menu and choose a video file in the open panel or simply
drag and drop the file onto the ZirkVideoPlayer window.

11.3 Supported File Types and Formats

As the app is built using the Apple AV frameworks, any video format that plays in Quicktime Player
will play in ZirkVideoPlayer.

11.4 Settings

The preferences panel (fig:11.1) is accessible from ZirkVideoPlayer -> Settings... menu.
In the preferences panel, you can configure playback settings on the General tab. On the Control

tab, enable receiving OSC messages, specify a network port for receiving incoming OSC messages
and see the possible OSC messages to control the video player. Additionally, you can enable MIDI
synchronization with Timecode or Clock. The default port number is 50001 but you can change the
port with the text field.
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Figure 11.1: Preferences Panel

R ZirkVideoPlayer can receive OSC and MIDI simultaneously, however ensure that transport
messages are not sent from both sources, ie. OSC /time message and MIDI Clock.

The movie volume slider in the general preferences panel controls the gain of the movie’s audio
tracks. You can mute the audio instantly by pressing the mute button (Speaker icon) in the main
window of the video player.

11.5 Synchronizing with Zirkonium3
To synchronize ZirkVideoPlayer with Zirkonium, Zirkonium should send OSC messages to the
video player. For the configuration, open the network settings tab by selecting Zirkonium3 ->
Settings -> Network.

Figure 11.2: Adding OSC Sender that sends messages to ZirkVideoPlayer

In the "OSC Senders" tab next to "Add Sender to Address", enter the IP address of the computer
on which the video player is running and the configured port. If you run the ZirkVideoPlayer on
the same machine, enter 127.0.0.1 (loopback) in the IP address field and press the "+" button (Fig.
11.2).

The newly created OSC sender will be displayed in the OSC Sender table. In the table, scroll to
the right and check the Transport column to enable playback message sending. Now Zirkonium is
able to send OSC messages to ZirkVideoPlayer.

R ZirkVideoPlayer starts the playback simply when it receives an OSC message. There are no
mechanisms to evaluate the synchronization or to correct it during the playback.

R It is also possible to send OSC messages from Zirkonium to multiple computers in the same
network and start movies on several computers simultaneously. To do so, define multiple
OSC senders in the Zirkonium Network settings OSC Sender table.
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12.1 What is ZirkPad?

Figure 12.1: Live spatialization with ZirkPad

ZirkPad is an iPad application that enables users to control the position and the span of each
ID or group in a Zirkonium project with the multi-touch interface remotely. This app is developed
mainly for three scenarios: live, placement, listening.

Live diffusion of more than two channels
With ZirkPad, you can spatialize up to 64 channels for sound sources and control the movement of
each sound source directly by dragging the virtual sound object displayed on the multi-touch screen.
In this way, ZirkPad offers an alternative live-spatialization strategy in contrast to the traditional
“diffusion”, a live expansion of stereo fixed-media using a mixing console and multiple stereo-pairs
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of speakers arranged in a listening space.

Sound reinforcement for a surround speaker system
Zirkonium is capable of patching live inputs and IDs, thus, ZirkPad can be used for live performance
with musicians. In this way, ZirkPad can assist the sound engineer in “placing” the audio signals
coming from each instrument onto a surround loudspeaker system.

Listening and controlling at various positions
Sound impression varies significantly depending upon the position of the listener and all concert
guests can not listen to the sound from the sweetspot simultaneously. Thus, we are often required to
listen and evaluate how the sound source is heard at the various positions of the listening space. As
ZirkPad runs on an iPad and sends message wirelessly to Zirkonium, you are able to walk around
the listening space and control the position of sound sources at the same time. This significantly
reduces the time for audio configuration before a concert.

12.2 System requirement

ZirkPad requires the following hardware/software environment:

12.2.1 Hardware Requirement

All iPads except the first generation iPad.

12.2.2 OS

iOS 9 or higher.

12.3 Network preparation

An iPad or multiple iPads, running ZirkPad, must be connected to the same local area network
(LAN) of the host computer, running Zirkonium as shown in figure 12.2.

ZirkPad

Zirkonium
Trajectory
Editor

iPad

ZirkPad

iPad

host
computer

Router

192.169.1.101 192.169.1.102 192.169.1.100

Figure 12.2: ZirkPad Network

R It is highly encouraged to use a dedicated router, assign static IP address for each device, and
use non-crowded WIFI channels for live performances.
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12.4 Installation

You can download and install the application from the App store.

12.5 Initialization

The following information will be sent from the Zirkonium to the ZirkPad. It is highly encouraged
to name all your IDs and groups before sending initialization message from the Zirkonium to the
ZirkPad.

• ID name
• ID color
• ID initial position
• Group name
• Group master
• Speaker positions

12.5.1 OSC sender setting

In order to send OSC messages from Zirkonium to ZirkPad, an OSC sender must be defined in
Zirkonium. To create a new OSC sender, open the Network settings tab by selecting Zirkonium3
-> Settings -> Network, then switching to "OSC Senders".

Figure 12.3: ZirkPad shows the IP address of iPad on startup

Figure 12.4: Typical setup for ZirkPad

1. Connect the computer and the iOS device to the same WiFi network
2. In Zirkonum, go to Zirkonium3 -> Settings -> Network, switch to "OSC Receivers" and

check the “Enable” box. Make sure the port number is set to 50000.
3. Launch the ZirkPad app on the iPad and check the IP address shown in the dome view on the

right side (Fig. 12.3).
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4. In Zirkonium, go to Zirkonium3 -> Settings -> Network, switch to "OSC Senders" and
enter the IP address of the iPad in the “Add Sender to Address” field at the bottom of the
OSC sender table.

5. Set the port number to 50001 and press the “+” button
6. A new sender will be created in the table
7. Scroll to the right, and enable the ZirkPad message to send ID and speaker levels to ZirkPad
8. Go to the Project settings Sync tab at File -> Project Settings -> Network Settings and

press Sync. Repeat this step when opening a new project in Zirkonium.
After syncing, ZirkPad should display the current Zirkonium IDs and speaker layout. Sync

again in order to update ZirkPad if you make changes to the project in Zirkonium on the computer.
If you change the configuration of IDs or groups in Zirkonium, you must sync again in order to

update ZirkPad.

Figure 12.5: Initialization

If ZirkPad doesn’t react to the sync messages from Zirkonium, check the network settings of
both devices.

12.6 GUI Overview

The figure 12.6 shows the main GUI of the ZirkPad.
On the right side of the screen, the multi-touch Dome view is displayed. It synchronizes with

the Dome view of Zirkonium and displays the position of speakers and sound objects as well as the
levels of the audio signals that each sound object generates and each speaker receives.

All IDs are labeled with the their names. The group networks are displayed with thin straight
lines. By default, all slaves are visualized with small circles and they are not controllable.

The left side of the window shows several buttons and switches to activate group-based
functionalities.

Global Lock Switch

This switch activates/deactivates all functionalities that the left pane of ZirkPad offers. By deacti-
vating the functions in the left pane, you can avoid unintended manipulations caused by touching
the left pane.

Global Button

If this button is pressed, all IDs in the dome view will be controlled parametrically. See 12.8.2 for
details.
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Figure 12.6: ZirkPad GUI

Group Button List
The group list shows the names of ID groups defined in groups table in the Trajectory editor. The
colors of the small rectangles next to the group names are the color of the Master ID of each group.

Group Modifier Button
When a group name is pressed, ZirkPad enters “Group mode” and allows you to control the
designated group in various ways. For details, refer to section 6.11.

Group Lock Button
When the group lock button is activated (locked), you cannot control the position of slaves in a
group. But once it is unlocked, you can control the position of each ID individually and change the
formation of the group.

12.7 Single ID Manipulation

Unlike the Dome view in Zirkonium, the sound objects in the Dome view in ZirkPad are touchable;
you can move ID objects that do not belong to any groups by dragging them with your fingers. As
soon as ZirkPad recognizes touches on sound objects, it sends OSC messages to Zirkonium. In
response to the received OSC messages, the Zirkonium updates the position of the sound objects
immediately.

In order to control the span (diffusion) of an ID, first touch the ID circle with one finger, then
place another finger on a empty part of the dome view, and drag it along the Y-axis. Then, a thin
circle will appear around the target ID. This circle indicates the current span of the ID.

12.8 Group-based Manipulation

If you want to control multiple IDs at once, ZirkPad offers two options:Direct mode and Parametric
mode.
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Figure 12.7: The Span circle indicated around an ID

12.8.1 Direct mode
Your can control the position of each ID just by directly dragging the master ID in the dome view.
Slave IDs follow the master ID using the translation or rotation mode described in chapter 6.

Note, slaves of a group cannot be touched by default because all groups are “locked”. However,
you can unlock the group by tapping the lock button next to the group name. If you move the
position of the slaves and lock the group again, the formation of the group will be changed.

12.8.2 Parametric mode
By touching the name of a group in the group list, you enter into parametric mode. You can exit
this mode by simply releasing your finger from the group list.

In the parametric mode, your finger gestures in the Dome view control the position of IDs that
belong to the pressed group relatively. The movement of the group is determined by the number of
fingers you use in the Dome view.

One Finger: Diffusion
If you use one finger and drag it in the Dome view along Y-axis, you change the span of all
designated IDs.

Two Fingers: Distance
If you use two fingers and swipe the Dome view along the Y-axis, you control the distance from the
center of all member IDs.

Three fingers: Rotation
If you use three fingers and swipe the Dome view, you rotate all the selected IDs.

Four fingers: Translation
If you use four finger and swipe the Dome view, you move all the selected IDs by translation.

By touching the global button above the group list, you can control all existing IDs and groups
using parametric mode.

12.9 Multiple manipulators

As the figure 12.2 shows, two or more manipulators can control a single instance of Zirkonium
simultaneously.
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However, if multiple manipulators are allowed to control all IDs, they may send different
commands for the same ID at the same time, and it may result in an abrupt “jump” of the ID
position.

In order to avoid this, you can limit the number of groups that a ZirkPad manipulator can
access. After syncing, each manipulator can remove specific groups from the group list by tapping
groups and the trash button at the same time. In this way, you can isolate the control of multiple
manipulators and avoid conflicts.
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